Experiment |ntroduction to VHDL , Quartus Il Software

7 and FPGA Board
Objective
The purpose of this laboratory is to give introduction to VHDL code using Altera
Quartus II software and thus, implement it on Altera DE1 board.
References
Stephen Brown and Zvonko Vranesic: Fundamentals of Digital Logic with VHDL
Design, 3rd Edition
Components
Altera Quartus II Software
Altera DE 1 Board
About the VHDL (VHSIC hardware description language) is a hardware description
Altera language used in electronic design automation to describe digital and mixed-
Quartus I signal systems such as field-programmable gate arrays and integrated circuits.
Software ) _ ) _
Altera DE 1 Altera Quartus II is a Computer Aided Design (CAD) software makes it easy

Board
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to implement a desired logic circuit by using a pro-grammable logic device, such
as a field-programmable gate array (FPGA) chip. A typical FPGA CAD flow is
illustrated in Figure 1.
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Programming and Configuration

Figure 1. Typical CAD flow.
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The CAD flow involves the following steps:

e Design Entry — the desired circuit is specified either by means of a schematic
diagram, or by using a hardware description language, such as Verilog or VHDL

» Synthesis — the entered design is synthesized into a circuit that consists of the
logic elements (LEs) provided in the FPGA chip

¢ Functional Simulation — the synthesized circuit is tested to verify its functional
correctness; this simulation does not take into account any timing issues

« Fitting — the CAD Fitter tool determines the placement of the LEs defined in the
netlist into the LEs in an actual FPGA chip; it also chooses routing wires in the chip
to make the required connections between specific LEs

» Timing Analysis — propagation delays along the various paths in the fitted circuit
are analyzed to provide an indication of the expected performance of the circuit

e Timing Simulation - the fitted circuit is tested to verify both its functional
correctness and timing

¢ Programming and Configuration — the designed circuit is implemented in a
physical FPGA chip by programming the configuration switches that configure the
LEs and establish the required wiring connections

The purpose of the Altera DE1 Development and Education board is to provide the
ideal vehicle for advanced design prototyping in the multimedia, storage, and
networking.

It uses the state-of-the-art technology in both hardware and CAD tools to expose
designers to a wide range of topics. The board offers a rich set of features that
make it suitable for use in a laboratory environment for university and college
courses, for a variety of design projects, as well as for the development of
sophisticated digital systems.



Procedure

Part A: Create a New Project

1.

On starting Altera Quartus II, you should be faced with a screen like this:
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Figure 1: The main Quartus Il display

2. Go to File -> New Project Wizard. An introduction Dialog will appear (Figure 2), It indicates

the capability of this wizard. You can skip this window in subsequent projects by checking the
box Don’t show me this introduction again.
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New Project Wizard: Introduction

The New Project Wizard helps you create a new project and preliminary project setlings, including the

following:

* Project name and directary

* MName of the toplevel design entity
* Project files and libraries

* Target device family and device
* EDA tool sethings

‘You can change the settings for an existing project and specify additional project-wide settings with
the Settings command [Assignments menu). You can use the varous pages of the Settings dialog box
to add functionality to the project.

[~ Don't show me this introduction again

Mext » | Cancel

Figure 2: Tasks performed by the wizard

3. Press Next to get the window shown in Figure 3. Choose the location of your working directory
and type in the name of your project (let’s use fulladder) as shown in Figure 3. Press Next.
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Mew Project Wizard: Directory, Mame, Top-Level Entity [page 1 of 5]

YWhat iz the working director for this project?
|D:'xh-1y Spmchhdp kM otetAlieratLabtLabd|

YWhat iz the name of thiz project?
(fulladider

L |

YWhat iz the name of the top-level design entity far this project? Thiz name is caze sengtive and must
exactly match the entity name in the design file.

|fu||au:|-:|er

Uze Exizting Project Settings ...

Mext = Finish Cancel

Figure 3: Creation of a new project

4. Since we have not yet created the directory lab1, Quartus II software displays the pop-up box
in Figure 4 asking if it should create the desired directory. Click Yes, which leads to the
windows in Figure 5.

| Quartus 1T l" m—r

Directory "D:/My Symc/My Whk/Note/Altera/Lab/Labl" does not exist.
Fd I % Do youwant to create it?

........................................

........................................

L

Figure 4: Quartus II software can create a new directory for the project
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5. The wizard makes it easy to specify which existing files (if any) should be included in the
project. Assuming that we do not have any existing files, click "Next”, which leads to the
window in Figure 6.

MNew Project Wizard: Add Files [page 2 of 5] [

Select the dezign files pou want to include in the project. Click Add &l to add all dezign files in the
project directory to the project. Mote: vou can alwars add design files to the project later,

File name |T',rpe | Librany | Design entry/sy... | HOL wversion Add Al

Eile name: | |

Rl

1| 1] [ b

Specify the path names of any non-default libraries. Uszer Libraries. .

< Back Mest = Finish Cancel

Figure 5: The wizard can include user-specified design files
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We have to specify the type of device in which the designed circuit will be implemented.
Choose “Cyclone™ II"” as the target device family. We can let Quartus II software select a
specific device in the family, or we can choose the device explicitly. We will take the latter
approach. From the list of available devices, choose the device called "EP2C20F484C7" which
is the FPGA used on Altera’s DE1 board. Press “"Next”, which opens the window in Figure 7.

-
Mew Project Wizard: Family & Device Settings [page 3 of 5]

==

Select the family and device you want ta target for cormpilation.

— Device family
Family: I Cvclone |1 ﬂ
Devices: I-"—"-" k1

— T arget device
™ Auto device selected by the Fitter

¥ Specilic device selected in ‘Available devices' list

— Show in Awvailable device' list

Package: Ay
Pin count; Ay
Speed grade: | Ay

¥ Show advanced devices
[T HardCopy compatible only

Ayailable devices:

M ame | Core v... | LE= | zerls... | kdemor.... | Embed... | PLL -
EF2C20F2RECY 1.2 18752 152 239616 B2 4
EF2C20F 25608 1.2 18782 152 2316 B2 4
EP2C20F25E15 1.2 18752 152 239616 B2 4
EF2C20F484CE 1.2 18752 315 239616 B2 4 |:|
EP2C20F434C7 1.2 35 2396 h2 4
EF2C20F4284C8 1.2 18782 215 2316 B2 4
EP2C20F4a413 1.2 18752 315 239616 B2 4
EF2C200240C8 1.2 18752 142 239616 B2 4 il
CDOTARCADATC 1 hd 27 C 277 AC204N N A

1| 0 | P

— Companion device

HardCaop: ;I

¥ Limit DSF & FAM to HardCopy device resources
< Back Next > Fsh | Cancel |

Figure 6: Choose the device family and a specific device
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F N
Mew Project Wizard: EDA Tool Settings [page 4 of 5] [

Specify the other EDA boals - in addition to the Quartuz || software -- uzed with the project.

— Design Entry/Synthesis

T ool name:

Formnat: I ;I

[T Fun thiz tool automatically to spnthesize the cument design

— Simulation

T ool name: I <Monesx

Ll L

Forrmat: I

I Fun gate-evel simulation automatically after compilation

— Timing Analysis

T ool name: I <Mones

Ll Lo

Farmat: I

[T Fun this tool automatically after compilation

< Back Mext = Finish Cancel

Figure 7: Other EDA tools can be specified

7. The user can specify any third-party tools that should be used. A commonly used term for CAD
software for electronic circuits is EDA tools, where the acronym stands for Electronic Design
Automation. This term is used in Quartus II messages that refer to third-party tools, which are
the tools developed and marketed by companies other than Altera. Since we will rely solely on
Quartus II tools, we will not choose any other tools. Press “"Next”.

A summary of the chosen settings appears in the screen shown in Figure 8. Press “Finish”,
which returns to the main Quartus II window, but with “lab1_YOURNAME" specified as the
new project, in the display title bar.
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Mew Project Wizard: Summary [page 5 of 5]

Froject directon:
Dby Somc/ty wi/MateddlteralLab/Labl f

Froject name: fulladder
Top-level design entity: fulladder
Murmber of files added: 1]

Mumber of user libraries added: 0

Device assignments:

Farnily name: Cyclone |l

Device: EP2C20F434C7
EDA tools:

Design enty/sunthesiz: <Mones

Simulation: <Mone

Timing analysis: <Mones

Operating conditions:
Core voltage: 1.2
Junction temperature range; 0-85 °C

< Back

Ww'hen you click Finigh, the project will be created with the following zettings:

Cancel

Figure 8: Summary of the project settings
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Part B: Example Project 1: Full Adder in VHDL

8. Select “File > New" to get the window in Figure 9, choose “"VHDL File”, and click "OK". This
opens the Text Editor window. The first step is to specify a name for the file that will be
created. Select “File > Save As” to open the pop-up box depicted in Figure 10. In the box
labeled “Save as type"” choose “"VHDL File”. In the box labeled “File name” enter fulladder.
Put a checkmark in the box “Add file to current project”. Click “"Save”, which puts the file
into the directory labl. Maximize the Text Editor window and enter the VHDL code as shown in

Figure 11. Save the file by typing “File > Save”, or by typing the shortcut Ctrl-s.

Mew

2]

i S0PC Builder System
=8 Deszign Filez
- AHDOL File
- Block. Diagram/Schematic File
- EDIF File
- State Machine File
- Spztemi'erlog HOL File
- Tel Secrpt File
- Wenlog HOL File

=~ Memom Files
- Hexadecimal [|ntel-Format] File
- bemony Irnitialization File
= Yenfization/Debugging Files
- In-Syztem Sources and Probes File
- Logic Analyzer Interface File
- SignalT ap I Logic Analyzer File
- wector Waveform File
= Otker Files

- AHOL Inchude File
- Block. Symbol File
- Chain Dezcription File
- Spnopays Design Constraints File
- Text File

]9

m

Caricel

Figure 9: Choose to prepare a VHDL file
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Networlk

r@ Save As M1
Savein: | | Lab1 j L IC_QF '
g Mame = Date modified Type
Flec::;:ﬂﬁams i lidb 12/27/201112:24 ... File folder

|
File name: Ifulladder j

Saveastype: | VHDL File {"vhd:"vhd) |

v &dd file to cuent project

Figure 10: Name the file

library IEEE:;

use IEEE.STD LOGIC 1164.ALL;

use IEEE.STD LOGIC ARITH.ALL;
use IEEE.STD LOGIC UNSIGHED.ALL:

entity fulladder is=
port ( a: in =std logic;
b: in =td logic;
cin: in std logic;
sum: out =td logic;
cout: out =td logic):;
end fulladder;

architecture Behavioral of fulladder is

2ignal =1,=22,23: std ulogic;

constant gate delay: Time :=100ps:

begin
2l<=(a xor b) after gate delay;

82<=(cin and =s1) after gate_delay;

23«<=(a and b} after gate delay:

sum<=({s1l xor cin)} after gate delay:
cout<=(=32 or =23) after gate_delay;

end Behawvioral:

Figure 11: fulladder VHDL code



Part C: Code Compilation

The code in the file fulladder is processed by several Quartus II tools that analyze the code,
synthesize the circuit, and generate an implementation of it for the target chip. These tools are
controlled by the application program called the Compiler.

1. Run the Compiler by selecting “Processing > Start Compilation”, or by clicking on the
toolt . con that looks like a purple triangle. As the compilation moves through various
stages, its progress is reported in a window on the left side of the Quartus II display.
Successful (or unsuccessful) compilation is indicated in a pop-up box. Acknowledge it by
clicking “"OK", which leads to the Quartus II display in Figure 12. In the message window,
at the bottom of the figure, various messages are displayed. In case of errors, there will be
appropriate messages given. When the compilation is finished, a compilation report is
produced. A window showing this report is opened automatically, as seen in Figure 12. The
window can be resized, maximized, or closed in the normal way, and it can be opened at

any time either by selecting "Processing > Compilation Report” or by clicking on the

icon

&

.
% Quartus II - D/My Symc/My Whk/Note/Altera/Lab/Labl/fulladder - fulladder - [Compilation Report - Flow Summary]

@Eile Edit View Project Assignments Processing Tools Window Help
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0=
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(=
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& fulladder. vhd
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vl W Analysis & Synthesis &S Flow Settings Quartus Il Version 9.0 Build 235 D6/17/2009 SP 2 SJ Web Edition
v P Fiter (Place & Route) S5 Flow Non-Default Global Se | Fevision Name P
W - Assembler (Generate programming fi @% Flow Elapsed Time Top-evel Entity Name fulladder
ol W Classic Timing Analysis -¢SHER Flow OS Summary Family Cyclone Il
-~ EDA Netlist Wrter & Flow Log Esnez SrzerREE
Program Device {Open Programmer)y []..@D Analysis & Synthesis Timing Models Final L
[]--@D Fitter Met timing requirements Yes 3
Total logic elements 2/18792(<1%)
-0 Assembler
. Total combinational functions 2/18792(<1%)
-1 Timing Analyzer
Dedicated logic registers 0/18752(0%)
Total registers 1]
Total pins 5/35(2%)
Total vitual pins 0
Total memory bits 07239616 (D %)
7 o b B o > Embedded Multiplier Sbit elemerts  0/52 (0% ) i
* Type | Message -
L] T
1) fo: The Active Serial/Parallel mode CONF DONE pin error check is disabled
j,) : Quartus II Assembler was successful. 0 errors, 0 warnings
\i') For **dkkkkkddddddhddddddrddd b ddddhdrddd b dddhhh b dddhh kb ddhhhhhh ko
j') fo: Bunning Quartus II Classic Timing Analyzer
j,) : Command: quartus_tan --read settings_file T ——write_settings_ files=off fulladder -c fulladder --timing_ana
\i.) : Longest tpd from scurce pin "cin" to destination pin "cout™ is 11.525 ns
j') : Quartus II Classic Timing Analyzer was successful. 0 errcrs, 0 warnings
i) : tuartna 7T Full Comnilatinn was succesatl. 01 errnra. 4 warninas S
4 1 +
% System [£] .\v\‘ Processing [52] ."{. Extra lnfa ;'\' Info (48] ;'\' ‘wiarning [4] ;'\' Critical W arning ;'\-,' Error ;'\' Supprezssed (5] ;'\' Flag l.-'r

ﬁ |Message: Oof114
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For Help, press F1
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=

Idle UM

Figure 12: Display after a successful compilation
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Part D: Pin Assignment

The DE1 board has hardwired connections between the FPGA pins and the other
components on the board. We will use two toggle switches, labeled SW0, SW1 and SW2, to provide
the external inputs, a, b and cin, to our example circuit. These switches are connected to the FPGA
pins L22, L21 and M22, respectively. We will connect the output sum and cout to the green light-
emitting diodes labeled LEDGO and LEDG1, which is hardwired to the FPGA pin U22 and U21. Pin
assignments are made by using the Assignment Editor.

1. Select "Assignments > Assignment” Editor to reach the window in Figure 13. Choose
Category as "“pin”. Enter the pin assignment as shown in Figure 13. Save the pin
assignment by select “File > Save”. Recompile the circuit, so that it will be compiled with
the correct pin assignments.

& Quartus I - D:/My Symc/My Wk/Note/Altera/Lab/Lab1/fulladder - fulladder -] ) [
File Edit Yiew Tools Window
@ A +  Category: | | Fin ﬂ ﬁ All | @ Timing | #* Logic Options |
FF S H ¥ Information: | Assigns a location on the device for the current node(s) and/for pin(s).
A Edit: ¥4 [ PIN_U21 |
To ¢ Location 1/0 Bank 1/0 Standare
ﬂ:ﬂ i =z PIM_L22 5 3. 3-VLNVTTL
2 b PIM_LZ21 3 3.3 VLVTTL
+ = |3 I cin PIN_M22 & 3.3V LVTTL
oo 2 5 I cout PIM_L22 B 3.3 VIVTTL
s» T |5 £ sum 6 3.3V LVTTL
EVINT A |5 <<news> <<news>
W - v b
For Help, press F1 MUM

Figure 13: The Assignment Editor window

Part E: Simulating the Designed Circuit

Before implementing the designed circuit in the FPGA chip on the DE1 board, it is prudent
to simulate it to ascertain its correctness. Quartus II software includes a simulation tool that can be
used to simulate the behavior of a designed circuit. Before the circuit can be simulated, it is
necessary to create the desired waveforms, called test vectors, to represent the input signals. It is
also necessary to specify which outputs, as well as possible internal point s in the circuit, the
designer wishes to observe. The simulator applies the test vectors to a model of the implemented
circuit and determines the expected response. We will use the Quartus II Waveform Editor to draw
the test vectors, as follows:
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1. Open the Waveform Editor window by selecting “File > New”. Click on the
“Verification/Debugging Files” branch to reach the window displayed in Figure 14.
Choose “Vector Waveform File” and click "OK".

[ Mew lﬁw

i S0PC Builder System -
=8 Deszign Filez
- AHDOL File
- Block. Diagram/Schematic File
- EDIF File
- State Machine File
- Spztemi'erlog HOL File
- Tel Secrpt File
- Wenlog HOL File
- %HDOL File
=~ Memom Files
- Hexadecimal [|ntel-Format] File

- bemony Irnitialization File
= Yenfization/Debugging Files
- In-Syztem Sources and Probes File

m

- Logic Analyzer Interface File
- SignalT ap I Logic Analyzer File

Wector Wavelorm File

= Otker Files

- AHOL Inchude File

- Block. Symbol File

- Chain Dezcription File

- Spnopays Design Constraints File

- Text File

] Caricel

Figure 14: Choose to prepare a test-vector file

2. The Waveform Editor window is depicted in Figure 15. Save the file under the name
fulladder.vwf. Set the desired simulation to run from 0 to 20 ns by selecting “Edit > End
Time"” and entering 20 ns in the dialog box that pops up like Figure 16. Selecting “View >
Fit” in Window displays the entire simulation range of 0 to 20 ns in the window.
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Quartus I - DMy Symc/My Wi/Note/Altera/Lab/Lab1/fulladder - fulladder - [fulladder.vwf] = | (S
y 2y y
Eile Edit View Project Tools Window
@ % A % @\ b aster Time Bar: B BB ns 4| | Pointer: 374 ps Interval: | -B28ns  Start: End:
Vot | P8 100ns 200ng
Name | 5 65ns 5.65ns
oo,
B 7] }
For Help, press F1 MNUM

Figure 15: The Waveform Editor window

[ End Time [ |

Time: |20 ns v

Default extenzion options:

Estenzion walue: |La$t clock pattern j

E nd time extenzion per signal:

Signal Mame | Direction | R adiz | Estension value |

k. | Cancel

Figure 16: End time window

3. Next, we want to include the input and output nodes of the circuit to be simulated. Click
“Edit > Insert > Node or Bus” to open the window in Figure 17. It is possible to type the
name of a signal (pin) into the Name box, but it is easier to click on the button labeled

“Node Finder” to open the window in Figure 18. The Node Finder utility has a filter used
to indicate what type of nodes are to be found. Since we are interested in input and output
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pins, set the filter to “Pins: all”. Click the “List” button to find the input and output nodes
as indicated on the left side of the figure. Select all signals and click the > sign to add it to
the Selected Nodes box on the right side of the figure. Click "Ok"” to close the Node Finder
Window and then “Ok" in the window of Figure 17. This leaves a fully displayed Waveform
Editor window, as shown in Figure 19.

-

Insert Mode or Bus

M arme: |

Tupe: INFUT

Walue type: | AL evel

Badi: SOl

E1
=]
=]

Buz width: |1

Start index; ||:I

[ Digplay gray code count as binary count

Cancel

iy

Mode Finder...

Figure 17: The Insert Node or Bus dialogue

Mode Finder [ﬁ
Mamed: |E j Filter: |F'in$: all ﬂ Cugtomize... | List | : akK |
Look, ir: [EELEEE(E jJ ¥ Include subentities | Cancel |
Modes Found: Selected Nodes:

Marne | Agzzignments | 1 M arne | Azzignments | ]
Ia PIM_LZ22 | A B [fulladderla PIM_L22 |
b PIM_L21 | B [fulladderlb PIM_L21 |
B cin PIM_td22 | B [fulladderlcin PIM_M22 |
I cout PIMN_LIZ2 [ < O [fulladderlcout PIN_LI22 i
L sum PIMN_U21 [ I [fulladderlsum PIM_LI21 [

<

4| 1 1| I

L

Figure 18: Selecting nodes to insert into the Waveform Editor
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1n) Quartus II - Di/My Symc/My Wk/Note/Altera/Lab/Labl/fulladder - fulladder - [fulladdervwi] =RNC X
File Edit View Project Tools Window
@ M aster Time Bar. B.EB hz 4| +| Painter: 198 ne Interval: 670 pz Start: End:
k A ey @\ Value gt 0 ps 'H].il} ns 200 n4
Name 5.65ns 5.65ns
4 4
=0 a AD
w1 b AD
w2 cin AD
o3 cout AX
8% 4] a4 sum AX
o4 I
For Help, press FL MUM

Figure 19: The nodes needed for simulation

4. Select signal a by first select the icon b , then click signal a. Then click the icon & to
bring up Figure 20 and fill in values as shown in that figure. Do the same to signal b and
cin by using period of 1000ps and 2000ps respectively. Then save the file.

Clock =3 |

Time range

Start trne: |EI | ps

=
End tirne: |2EI.EI | Nz j

B aze wavefarm an

|500 s v
Offset |0 pz |

Dty cocle [Z] |50

=

] | Cancel |

L

Figure 20: Clock waveform setting for a
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5. To perform the functional simulation, select Assignments > Settings to open the
Settings window. On the left side of this window click on Simulator to display the window in
Figure 21, choose Functional as the simulation mode, and click OK. The Quartus II
simulator takes the inputs and generates the outputs defined in the fulladder.vwf file.
Before running the functional simulation it is necessary to create the required netlist, which
is done by selecting Processing > Generate Functional Simulation Netlist. A

simulation run is started by Processing > Start Simulation, or by using the icon . At
the end of the simulation, Quartus II software indicates its successful completion and
displays a Simulation Report illustrated in Figure 22.

P ~
Settings - fulladder |

Category:
- [Feneral
- Filez
- Libraries Select simulation options.
- Device
- Operating Settings and Conditions ) . -
o . Simulat de:
[+ Compilation Process Settings e |Funct|0na| j
- EDA Tool Settings Simulation input; |fulladder.vwf Add Multiple Files... ‘
[~ Analysiz & Spnthesiz Sethings
- Fitter Settings Simulation period
(- Timing Analysis Settings {* Run simulation until all vector stimul are used
- Agzembler
- Diesign Assistant " End simulation at: | |n$ j
- SignalTap Il Logic Analyzer
- ode .fl‘-.nayzer Intertace Glitch filteritg options: |Autn ﬂ
238 Simnulator Settings
- PowerPlay Power Analyzer Settings Mare Settings...

- 55 Analyzer

Dezcription:

Specifiez the end time for simulation.

] | Cancel

Figure 21: Specifying the simulation mode
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& Quartus I - Di/My Symc/My Wk/NotefAltera/Lab/Lab1/fulladder - fulladder - [Simulation Report - Si.. o ) e
File Edit View Project Tools Window
Simulation Waveforms
Simulation mode: Functional -
[% kaster Time Bar: B ED Rs 1| v| Pointer: 913 ns Interval: 348 ns Start: End:
A D ps 10.0ns 200nd
Walue at ]
s MName 5 BAns 5 65ns
@ o0 a AD
[T b Al
[ 1 cin A1
l:? 3 cout A1
+ | d sUm AD
— |1 r
For Help, press F1 MLUM

Figure 22: The result of functional simulation

Part F: Programming and Configuring the FPGA Device

The programming and configuration task is performed as follows.

1. Flip the RUN/PROG switch (on DE1 Board) into the RUN position. Select Tools >
Programmer to reach the window in Figure 23. Here it is necessary to specify the
programming hardware and the mode that should be used. If not already chosen by
default, select ITAG in the Mode box. Also, if the USB-Blaster is not chosen by de fault,
press the Hardware Setup... button and select the USB-Blaster in the window that pops up,

as shown in Figure 24.

@ Quartus I - DMy Symc/My Wk/Note/Altera/Lab/Labl/fulladder - fulladder - [fulladder.cdf]

{

™ ™

File Edit Window

&, Hardware Setup...| | USB-Blaster [USB-0]

[ Enable realtime ISP ta allow background pragramming [far b || devices)

Processing Tools

Made: |JTAG

j Progress:

[=]
i3

Blark.-
Check

Program./
Configure

# Start | File Device Verify

| Checksum | Usercode

. Se
Examine

curity

Bit | Bl

fulladder saf EP2C20F454 OOTBOBES  FRFFRFFF 0

Stop

all A1it0 Detert |
For Help, press F1

Ll 1

NUM

Figure 23: The Programmer window
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-

Hardware Setup

S

Hardware Settings | JTAG Seftings

hardware setup applies anly ta the current programmer windaw.

Currently zelected hardware:

Available hardware items:

Select a programming hardware setup to use when programming devices. Thiz programming

Hardware Server | Port Add Hardware... |

'l I15B-Blaster Local 15E-0

Close

Figure 24: The updated Programmer window

2. Observe that the configuration file fulladder.sof is listed in the window in Figure 24. If the
file is not already listed, then click Add File and select it. This is a binary file produced by
the Compiler's Assembler module, which contains the data needed to configure the FPGA
device. The extension .sof stands for SRAM Object File. Note also that the device selected is
EP2C20F484, which is the FPGA device used on the DE1 board. Click on the
Program/Configure check box, as shown in Figure 23. Now, press Start in the window in
Figure 23. An LED on the board will light up when the configuration data has been
downloaded successfully. If you see an error reported by Quartus II software indicating

that programming failed, then check to ensure that the board is properly powered on.
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